Help us to help you!

Our aim is to offer you the best service possible, to do this we need to know: (1.) Joomla! version (2.) Server type (3.) Editor version (4.) JCK Manager version and (5.) any error messages you may have. For help in finding errors please - click here…We would also invite you to read our form rules before posting - read more…

Welcome, Guest
Please Login or Register.    Lost Password?
Forum is locked
Problem when adding a background image to a table cell in 3.4.5 Forum is locked
(1 viewing) (1) Guest
This is a list on known issues that will be addressed in the next official version release.
Go to bottomPage: 1
TOPIC: Problem when adding a background image to a table cell in 3.4.5
#2121
Problem when adding a background image to a table cell in 3.4.5 3 Years, 6 Months ago Karma: 32
One of our users has found a problem when adding a background image to a table cell. This was discovered when using the “CKcss Inline CSS Editor”.

For some reason """ are being added to the URL which is causing the image not to display on the front end.

Code:

<td style="background-image: url(&quot;files/toolbar_twitter.png&quot;);">

A simple workaround is to delete ' &quot; ' from the image URL path which fixes the issue however, if you reopen the editor the ' &quot; ' are re-added breaking the background image again.
Paul (Team Member)
Administrator
Posts: 2065
graph
User Offline Click here to see the profile of this user
Gender: Male webxsolution.com Location: London Birthday: 12/09
Last Edit: 2011/03/17 12:48 By awills.


Kindest regards,

Paul Franklin

If you use JCK Editor, please post a review at the Joomla! Extensions Directory.
The topic has been locked.
 
#2142
Re: Problem when adding a background image to a table cell in 3.4.5 3 Years, 6 Months ago Karma: 16
This issue does seem to occur especially in Firefox 3.6+
Awills (Team Member)
Administrator
Posts: 1090
graphgraph
User Offline Click here to see the profile of this user
Gender: Male webxsolution.com Location: London
Last Edit: 2011/03/15 15:30 By awills.

Always clear your browser cache(CTRL+SHFT+DEL for FF/IE and Chrome users)
The topic has been locked.
 
#2172
Re: Problem when adding a background image to a table cell in 3.4.5 3 Years, 6 Months ago Karma: 16
How to add a data processor beacuse CKEDITOR refuses to fix this issue that is prevalent in Firefox resulting in &quot; being added to the URL of the background image.

this url(&quot;files/toolbar_twitter.png&quot;) is actually correctly CSS and saves correctly to the database and actually displays correctly in the browser directly. Howwever, it is the post processing that occurs when an article loads up in the front end of Joomla that is causing the issue.

The data processor removes the &quot; for backgrund images.

This has been packaged in next release of the editor
Awills (Team Member)
Administrator
Posts: 1090
graphgraph
User Offline Click here to see the profile of this user
Gender: Male webxsolution.com Location: London

Always clear your browser cache(CTRL+SHFT+DEL for FF/IE and Chrome users)
The topic has been locked.
 
Go to topPage: 1

Share this post